Get exclusive deals delivered to your inbox!

Start saving today. »

NewerTech USB Display Adapters: 10.13.4 Notice

Created on: March 15, 2018

Relevant Part Numbers:

  • NWTVIDU3DVIA
  • NWTVIDU3MDP

 

As of 03/15/18, the NewerTech USB 3.0 to DVI Video Adapter and the NewerTech USB 3.0 to 4K DisplayPort Adapter are not compatible with the beta versions of macOS 10.13.4. The incompatibility is due to a conflict with the DisplayLink technology used in these devices. NOTE: this incompatibility is not limited to NewerTech products.

DisplayLink and Apple are aware of the issue and working towards a resolution. In the meantime, if the use of these adapters is paramount to your Mac computing activities, we strongly recommend that you continue using macOS 10.13.3 or earlier, until such time as a fix is available. If the need to upgrade to 10.13.4 takes precedent, you should find a way to drive your display(s) without use of the above-noted adapters, until a fix is available.